ExamWRITER Secure Messaging & Patient Portal Upgrade

If you or providers in your practice are required to participate in MIPS in 2019 and beyond, you must use ExamWRITER 15.0, which is a 2015 Edition Certified EHR.

Additionally, you’ll need to upgrade your secure messaging and patient portal platform to meet the higher MIPS standards. This new platform will replace your existing one and includes the following components:

  • A friendlier patient portal
  • More modern secure messaging
  • A new quality measure tracking and reporting module

The new features deliver a more streamlined workflow to make MIPS easier to navigate and monitor:

  • Clinical data are automatically uploaded to the patient portal.
  • Patients are automatically sent an invitation to the patient portal when the exam is finalized.
  • Provider contact list saves secure messaging addresses so you don’t have to remember them.
  • Dynamic quality measure reporting makes it easier to track your Quality performance.

You must sign up for and be actively using these new features prior to beginning your Promoting Interoperability performance period in 2019. Complete the form below to register your interest, and we'll reach out to you soon.

Check Your MIPS Eligibility First

 

NOTE: This form is for ExamWRITER customers only. If you're an Eyefinity EHR customer, the patient portal and secure messaging have not changed, and you don't need to complete this form.